Uploaded image for project: 'SR for Jira - Development'
  1. SR for Jira - Development
  2. SRJIRA-612

linkedIssuesOfRemote does not work with "?" in the URL

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Done
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1.4
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:

      JIRA 6.4.7

    • Critical Points:
      0

      Description

      Hi,

      I am trying to query my Issues for specific Confluence Links. So I linked an Issue to a Confluence Page with the URL (for example) http://my.server.com/confluence/pages/viewpage.action?pageId=2097319* and used a query like *issuefunction in linkedIssuesOfRemote("http://my.server.com/confluence/pages/viewpage.action?pageId=2097319") but I get no results (even after manually starting the indexing process). I tried some stuff and it looks to me, that when specific characters are used inside the URL (for example "?" or "&") it is not possible to query them any more...

      (Originally posted @ Atlassian Answers

      I am using JIRA 6.4.7 with ScriptRunner 3.1.4 and also tested 3.0.11.

      TIA

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jechlin Jamie Echlin
              Reporter:
              klemensl Klemens Loschy
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: